DesktopServer – Create locally installed WordPress Websites Forums Public Discussions PHPMyAdmin Error – You should upgrade to MySQL 5.5.0 or later.

This topic contains 4 replies, has 2 voices, and was last updated by  Alain P 1 year, 4 months ago.

  • Author
    Posts
  • #44038

    Alain P
    Participant

    Hi, I was excited to try the new version 3.8 and although I do see the new revamped Sites page, when I click at the top “Tools–>PHPMyadmin” I get a page with a red bar that says “phpMyAdmin – Error” and on the next line: You should upgrade to MySQL 5.5.0 or later.

    I’d love if someone could help out. I did what I could to investigate…for example in “Tools–>PHP Information”, if i do a search on sql I get something that seems to indicate a lower version (?) : mysqlnd 5.0.11-dev

    But if I try to upgrade using the manual version, the command prompt window confirms that I’m already upgraded to version 5.6.24

    PLEASE HELP!!!

  • #44039

    Alain P
    Participant

    Looks like the attached screenshot here..

  • #44092

    Hello Alain,
    Unfortunately this can popup but may be misleading. Can you try the http://localhost/phpmyadmin address in another browser? It appears that certain cookies, and occasionally aggressive caching within the local browser that can cause this.

    If it does resolve in another browser, simply go back to your preferred browser and try to either clear the cache, or first visit the page with a GET parameter to force a refresh; like so:

    http://localhost/phpmyadmin/?xyz123

    Please let us know if this does not resolve the issue or if you need further assistance.

    Regards,
    Stephen

  • #44156

    Alain P
    Participant

    Hi Stephen… the first link you provided gave us an interesting clue.
    It took me straight into the phpmyadmin page (no password request), and it does indeed show MySQL Community Server 5.6.24 and php 4.4.6.

    When I was getting the mysterious red bar error, the URL was “http://127.0.0.1/phpmyadmin” rather than what you provided. Would this make a difference?

    Anyway, after trying your link, I tried it again from the Xamplite sites page and this time it worked and once I was in the URL looked pretty similar to where I ended up following your link…something like “http://127.0.0.1/phpmyadmin/#PMAURL-0:index.php?db=&table=&server=1&target=&token=6c99b48fdf35cc19310a6b826233ab01”

    Something to note is that between the time I had the error message and your solution, my computer was put to sleep mode. Would this also have made a difference?

    FWIW, the browser being used is Chrome (regular mode, not incognito).

  • #44158

    Alain P
    Participant

    I also accidentally broke my sql connections by failing to make a copy of the sql/data folder to restore manually after the upgrade, but thankfully i had not done much work on the sites yet. Anyway, lesson learned.

    I noticed however that the Sites page still populates with all the projects – how can it do that if I ended up wiping the whole xamplite folder? Where is it reading this from?

The forum ‘Public Discussions’ is closed to new topics and replies.