This topic contains 5 replies, has 4 voices, and was last updated by  Cathy Earle 1 year, 1 month ago.

  • Author
    Posts
  • #35657

    Jim Chapman
    Participant

    I’m on my MacBook Pro. I tried to download you DeskTopServer application but the download fails every time. Not sure why.

    Anyway, I have a downloaded version I got from you on my iMac. I moved it over to the MacBook Pro and proceeded to run it. It unzipped fine. Then I attempted to install and got a NilObjectException error and everything stopped.

    So, I read your manual install instructions and copied the XAMPP directory to my Applications directory. Then I attempted to run DeskTopServer. Upon open, I get an error stating, “Error – Unable to locate and set Documents/Websites folder.

    I have created a Documents/Websites folder on my data drive. I use Symbolic Links since I have a 256GB SSD for applications and operating system, and a 500GB HDD for data. Is the use of Symbolic Links causing an install problem?

    Further, after I click on the “OK” button for the directory error, I still get the NilObjectException error.

    Please help one more time. Sorry to be such a pain!

    Thanks, Jim C
    guardsix6@gmail.com

  • #36088

    Gregg Franklin
    Keymaster

    Hello Jim,

    Were you successful at installing DesktopServer? I wanted to reach back out and see if you were still stuck.

  • #36134

    Jim Chapman
    Participant

    Hi, just got back home from running some errands.

    I finally got the purchased version of DeskTopServer download on my iMac and my MacBook Pro.

    The install on my iMac went perfect. I did the upgrade installation and it seems to be working just fine.

    I tried to use the Direct Deploy feature to move my dev web site to my .com (live) web site but I keep getting an error telling me that it can’t find the “xmlrpc.php” file. I can see it’s there in my guardsix6.com directory so I don’t know what’s going on with that.

    As for my MacBook Pro. I still can’t get it to install. I tried both ways, automatic and manual and I’m getting errors both ways. Unable to find Document/Website folder and then the NilObjectExecution error.

    I just did a permissions repair on my SSD and there were a few that had to be fixed. I’ll try to re-install again and see what happens.

    I should be home for the rest of the afternoon until about 5 pm. If you want to connect, I’m here.

    Jim C.
    guardsix6@gmail.com

  • #36282

    Jim Chapman
    Participant

    Still not working on the MacBook Pro with Yosemite 10.10.3. Repairing permissions apparently did not fix anything.

    Sure would like to get my live web site updated and be able to use my MacBook Pro to work on dev site.

    Jim C.

  • #36284

    Hello Jim,
    Thank you for your follow up. Can you furnish us with your preferences file? Here is how:

    https://serverpress.com/doc/how-to-open-the-desktopserver-preferences-file/

    We’ll want to know the first 10 or 15 lines of text, including the webOwner value.

    Thank you for your patience,
    Stephen

  • #116296

    Cathy Earle
    Participant

    Hi Stephen,

    I have this same error “can’t find the “xmlrpc.php” file. I can see it’s there in my directory.”

    I am trying deploy to DreamHost.

    Cathy

The forum ‘Public Discussions’ is closed to new topics and replies.