skip to Main Content

Tagged: ,

Viewing 12 reply threads
  • Author
    Posts
    • #30237
      Laure
      Participant

      I installed DesktopServer and it seems to work, however it only opens in Safari, which is a fairly useless browser. I want to switch it to firefox, but I can’t find a preference panel where I can do that. Please help!

    • #30289
      Gregg
      Keymaster

      Hello Laure,

      You will need to make a change in the preferences file. You can find where your preferences file is by reading this documentation.

      https://serverpress.com/doc/how-to-open-the-desktopserver-preferences-file/

      Open this file in your favorite text editor and go to around line 7

      “browser”:”Safari”,

      Change it to

      “browser”:”Firefox”,

      and save.

    • #32232
      Laure
      Participant

      I did as you suggested and there was an error. I am including screenshots.

    • #32254
      Gregg
      Keymaster

      Hi Laure,

      Looks like the quotes around Firefox are the wrong type. “Firefox” cut and paste this in and replace the existing one.

      Please let us know if this does not resolve the issue or if you need further assistance.

    • #32439
      Laure
      Participant

      Hi Gregg,

      It didn’t resolve the issue but the error message is slightly different.

    • #33258
      Laure
      Participant

      I’d be happy to PM you a screenshot of the full prefs file if it could help diagnose the error.

    • #38731
      Jamie Bergen
      Participant

      Thanks! I was able to switch the default browser to Firefox using your instructions.

    • #38752
      Gregg
      Keymaster

      Hi Laurie,

      If you could send me the preferences file I can take a look at it.

    • #43773
      paulzz
      Participant

      Same problem here. Changed Safari to Firefox and now get same error message. How did you fix it?
      Would be useful to post it here so we don’t have to ask.

      Thanks

    • #43774
      paulzz
      Participant

      It’s the quote marks. Some of them are smart “ while they should be standard ”

      The offending marks are after “browser“: and both around the browser name.

    • #43806
      Gregg
      Keymaster

      Open your preferences file
      https://serverpress.com/doc/how-to-open-the-desktopserver-preferences-file/

      Change around line 6:  “browser”:”Safari”,

      to “browser”:”Firefox”,

      or “browser”:”Chrome”,

    • #43811
      paulzz
      Participant

      Hi Gregg
      Thanks, I did work it out but the problem was caused by the wrong kind of quotes. See previous post.

    • #43813
      Gregg
      Keymaster

      Open your preferences file
      https://serverpress.com/doc/how-to-open-the-desktopserver-preferences-file/

      Change around line 6:  “browser”:”Safari”,

      to “browser”:”Firefox”,

      or “browser”:”Chrome”,

Viewing 12 reply threads
  • The topic ‘How to change default browser’ is closed to new replies.