Tagged: ,

This topic contains 5 replies, has 3 voices, and was last updated by  Stephen J. Carnam 1 year, 4 months ago.

  • Author
    Posts
  • #43248

    Jason King
    Participant

    Hi there just tried to run a deploy (with 3.8) and was unable to complete. Attached is the error message.

    I did add a .git file and a netbeans project directory to the WP site, is that hanging it up?

    What do you think

  • #43298

    Gregg Franklin
    Keymaster

    Hello Jason,

    Are you still able to view the site locally? This type of error usually is displayed if the site root folder has been moved.

    We can do an assisted deployment for you.

    For assisted deployment, please create a website archive to privately upload to our server

    Use DesktopServer’s last option to “Import, export or share…”, followed by “Export or deploy…”.
    Select your website project from the drop down combo box, “From Website”.
    Ensure that the option is set to “Export to a website archive”.

    You you do not need to supply any additional information. Skip filling out any additional fields and just click “next” until a zip file is produced. You may then upload the created zip file via our website at:

    https://serverpress.com/doc/assisted-deployment/

    Please note that there is a 300MB limit on the upload page. If your .zip archive is larger than 300MB, you may wish to use a third-party service, such as dropbox.com to send us the file. Dropbox requests can be sent to our email (support@serverpress.com). In lieu of dropbox.com or our upload page, you may send us a URL to obtain the file.

    • #43409

      Jason King
      Participant

      Well I did not move the root folder, so that is a bit confusing. I’ll look at my site structure again. Maybe my netbeans project folder messed it up…

  • #43417

    Jason King
    Participant

    I just tried to copy the site with DS and got the same error.

    I can view the site locally just fine and go into admin.

    I had a large file warning in duplicator when attempting to make a backup..

    D:/www/www.nextmark.dev/.git/objects/7d/32951a8fa5a29914c4c011f653129726584f78 [56.3MB]

  • #43420

    Jason King
    Participant

    Yeah something about .git in the site structure was hanging it up, its deploying now that I have removed git.

  • #43607

    Hmm, that is unusual. DesktopServer removes the .git folder prior to creating an export zip or performing a DirectDeploy. However, the initial operation is a “copy”, which may cause undue stress if the .git archive is very large. After the copy operation completes, DesktopServer purges any project folders and files on the copy: .git, .gitignore, _Notes, .svn, etc. However, we will make a note of this (ideally it wouldn’t perform the copy from the start on those given folders).

    Thank you for your feedback.

The forum ‘Public Discussions’ is closed to new topics and replies.