skip to Main Content

DesktopServer – Create locally installed WordPress Websites Forums Public Discussions development website folder not found, sites button greyed out

Viewing 2 reply threads
  • Author
    Posts
    • #135360
      Joseph Baker
      Participant

      I recently “refreshed” Windows 10. It re-installed Windows, but did not erase my personal files, such as my “Websites” folder for DesktopServer. However, it did erase all my applications. I had to re-install Desktop Server.

      Now that everything is re-installed, when I open DesktopServer, it starts ok. It finds “localhost”. But when I go to “localhost”, no development websites are listed.
      I have not changed my file structure. I still have one development website in the default location:
      C:\Users\joe\Documents\Websites
      I don’t understand why DesktopServer doesn’t see that I have a development website where it should be.
      Even when I go to localhost->Tools->PHPMyAdmin the database for my website is still there.
      Also, the “Sites” button on DesktopServer is greyed out, as if there are no sites.

    • #135378
      Gregg
      Keymaster

      Hello Joseph,

      DesktopServer is made of three components, the /xampplite folder (containing the application and the databases), the folder where you selected to have all your websites files stored and the preferences file.

      If you have a backup you can restore the preferences file. Learn more about it: http://docs.serverpress.com/article/84-how-to-open-the-desktopserver-preferences-file

    • #135381
      Joseph Baker
      Participant

      I don’t have a backup. Is there anyway I can change the preferences file so it can find my website folder?

      The preferences file looks like this
      {
      “version”:”3.8.0″,
      “edition”:”Limited”,
      “webOwner”:””,
      “dbUser”:”root”,
      “dbPass”:””,
      “browser”:”Chrome”,
      “tld”:”.dev”,
      “ds-plugins”:{},
      “desktop”:”C:\\Users\\joe\\Desktop”,
      “documents”:”C:\\Users\\joe\\DOCUME~1\\Websites”,
      “sites”:{}
      }

Viewing 2 reply threads
  • The forum ‘Public Discussions’ is closed to new topics and replies.