DesktopServer – Create locally installed WordPress Websites Forums Public Discussions DesktopServer stalls at my sites unless turn off 6 services

Tagged: 

This topic contains 2 replies, has 2 voices, and was last updated by  Rob Healey 1 year, 2 months ago.

  • Author
    Posts
  • #92587

    Rob Healey
    Participant

    I can only use DesktopServer if I open cmd as Admin, type ‘net stop http’ and say yes to turning off 6 services, one of which is the print spooler. This is annoying because I sometimes need to print.
    Do all these services need to be turned off?
    UPnP Device Host
    SSDP Discovery
    Print Spooler
    Homegroup Provider
    Function Discovery Resource Publication
    Function Discovery Provider Host

    I don’t know CMD commands, if only one or two or three need to be turned off, what are their code names, so that I can type ‘net stop codename’ for each one.

    I have tried going to Computer Management>Services and looking for IILS and WWW something, but neither are there and it seems like a much slower way.

  • #92779

    Gregg Franklin
    Keymaster

    Hello Rob,

    You do not have to turn off all those services. It looks like the built in Microsoft Web Server is on. You can stop and disable this by doing the following:

    Type services.msc from the run command prompt > scroll down to World Wide Publishing service.

    or go to control panel > Administrative Tools > Services.msc > World Wide Publishing service.

    More info: https://technet.microsoft.com/en-us/library/cc732317%28v=ws.10%29.aspx

  • #93055

    Rob Healey
    Participant

    Thanks very much Gregg. I didn’t know how to analyse what was preventing DS from working. You are correct, it was only the Word Wide Web Publishing Service holding things up.
    I googled and it is not part of Windows 7, so I have changed the start up settings from ‘Automatic’ to ‘Manual’ by typing ‘services.msc’ in the run command prompt > scroll down to World Wide Publishing service, double clicking it to open an applet with all its settings. (In case this helps anyone else)

    I restarted the PC and DS opened and works.

    If I discover something else installed requires WWWPS, it’s easy to turn it back on.

The forum ‘Public Discussions’ is closed to new topics and replies.