#29150

This issue can occur on Macintosh systems with incorrect hard drive permissions that prevent the database from functioning normally. Are you on Mac? For additional support, please be sure to include your operating system version (i.e. Windows 8.1, Mac OS X 10.9.4, or Ubuntu 14.04).

If you are on Macintosh, please take a moment to correct the issue with either a hard drive permissions repair or take possession of the temp folder. Be sure to do this while MySQL and Apache are not in memory (if in doubt, please reboot). Here is how:

1) Use Finder to go to the folder at “/Applications/XAMPP/xamppfiles”.
2) Right-click (Ctrl+Click) the “temp” folder and select “Get Info” from the pop-up context menu.
3) Unlock the folder and set the “Sharing & Permissions” (bottom of panel) for “Everyone” from Read & Write.
4) Enforce the permissions settings to all enclosed items using the ‘gear like’ button icon and selecting the popup menu “Apply to enclosed items…”.

Do the same for the “/Applications/XAMPP/xamppfiles/var”

You may now start DesktopServer and use the first option to “Stop or restart…”, followed by the “Restart…” option. This will cycle the development server on and off and should correct the problem.