Home Forums Premium Support DesktopServer Support Can not find dev site

This topic contains 31 replies, has 3 voices, and was last updated by  Stephen Carnam 2 years ago.

Viewing 30 posts - 1 through 30 (of 32 total)
  • Author
    Posts
  • July 29, 2012 at 7:17 pm #5389

    stano7
    Subscriber

    When clicking on my link for my dev site I get “Can not find server” error.

    I have uninstalled xampp and vhost folders on my C drive and reinstalled the premium serverpress program.

    tested mysqld.exe is in my c:\xampplite folder but no httpd.exe listed in services.

    nothing running on ports 80, or 443.

    Running on a windows 7×64 machine.  Help?

     

    I am running on a windows 7 x64 machine.

    July 29, 2012 at 9:43 pm #5390

    Stephen Carnam
    Key Master

    Hello Stano7,
    Thank you for including your platform and issue description. Please take a moment to post your error log file (or feel free to send it to us privately – support@serverpress.com). You can find this file at c:\xampplite\apache\logs\error.log. This text file might indicate why apache (httpd.exe) is not loading/or it may provide us with additional clues.

    Thank you for your patience,

    Stephen

    July 30, 2012 at 5:21 am #5394

    stano7
    Subscriber

    I looked for the error.log file in the apache folder and do not have it.  There is a folder called error/ but there isn’t a log file in that folder either.

    July 30, 2012 at 1:29 pm #5396

    Stephen Carnam
    Key Master

    Hello Stano7,
    I’m sorry to hear this. It sounds like apache won’t even begin the writing of the error.log file. This might be because of an incomplete installation. To resolve this issue; try using the downloaded premium version’s installer and select the Upgrade option. This will repair/re-install the application. If the problem persists, you can do a manual installation. Here is how:
    1) Unzip the downloaded zip file from our web site at http://serverpress.com/downloads
    2) Open the libs folder and drag the contents of the xampplite folder to your c:\ drive. You should have a c:\xampplite folder on your system
    3) Open the c:\xampplite folder and right-click the blue DesktopServer.exe icon, followed by selecting “Pin to Start menu”. Please let us know if this does not resolve the issue.

    Thank you for your patience!

    Regards,

    Stephen

    July 31, 2012 at 5:14 pm #5432

    stano7
    Subscriber

    I tried both of your installation suggestions and both failed.  Same error message.

    One clue is that everything worked fine when I was using the “lite” version but stopped after I downloaded and installed the “premium” version.  Again, I am on a 7×64 machine.   Don’t know if that makes a difference.

    July 31, 2012 at 5:22 pm #5433

    Stephen Carnam
    Key Master

    Hi Stano7,
    I’m sorry to hear this. The difference between the two are very subtle. A few extra files in the Premium version, but the service should at least start an error log.  The installer should have gracefully shut down your services and upgraded your existing installation to preserve your work. However, if you used the uninstall option, the installer should have gracefully shut down your services and removed the application.

    Back to your original post “I have uninstalled xampp and vhost folders on my C drive”, please let us know how you did the “uninstalled xampp”? Did you use the Installer’s Uninstall/Re-install option? If not, did you shutdown the services before uninstalling?

     

    July 31, 2012 at 5:27 pm #5434

    Stephen Carnam
    Key Master

    Please note that deleting files while in memory may result in an unpredictable state or incomplete un-installation. Please take a moment to reboot your system to ensure that all files are properly closed. You can then use Installer’s Uninstall option to remove any left over elements.

    Lastly, some third party anti-virus applications can interfere with installation and DesktopServer’s normal operation. Please let us know what kind of anti-virus application or anti-malware applications you might be running.

    Your patience is greatly appreciated!

    Regards,

    Stephen

    August 1, 2012 at 4:48 am #5442

    stano7
    Subscriber

    I did an uninstall from the XAMPP installation program but noticed that the C:/xampp folder was still there after the uninstall so I deleted that folder.  I also just deleted the vhost folder.

    I have run the serverpress program with my security software OFF with the same results.  I am using System Suite Professional.

    IS there a manual sweep of the XAMPP, MYSQL files that I can do to insure that all of the associated files are removed from my system?

    August 1, 2012 at 5:10 am #5443

    Stephen Carnam
    Key Master

    Hello Stano,
    Please note that you should only have one web server installed; attempting to run two MySQL/Apache instances can create cross-talk and file system corruption. It appears that you might be/have been running another copy of XAMPP (as you stated c:\xampp). DesktopServer does not install an c:\xampp folder.

    DesktopServer comes with it’s own flavor of XAMPP and MySQL. The only folders that you need to remove are:

    c:\xampplite

    and

    c:\ProgramData\DesktopServer

    DesktopServer’s installer will remove these folders in addition to the start-up icon on your start menu.

    Unfortunately we are not familiar with the XAMPP deviation you might have installed or additional services associated with it. There are several options on the original XAMPP that can install system startup services (which we do not recommend as this can inhibit DesktopServer’s WordPress centric copy/import/create functionality). To ensure these services are not present, reboot and upon login, please take a look at your Task Manager for the httpd.exe and mysqld.exe processes (be sure to view the process list for all users via the “All Users” button).

    Please let us know if this does not help resolve the issue.

    Regards,

    Stephen

    August 1, 2012 at 5:23 am #5444

    stano7
    Subscriber

    Here is what I have done:  I turned my virus and firewalls OFF.  I uninstalled Serverpress using the unistall option in the installation program.  Rebooted.  Downloaded a fresh copy of the Premium program.  Reinstalled it and ran the program. Same result with the “Can’t find server error”.

    August 1, 2012 at 5:25 am #5445

    stano7
    Subscriber

    httpd.exe and mysqld.exe processes were not running when I did the fresh install.

    August 1, 2012 at 5:30 am #5446

    Stephen Carnam
    Key Master

    Do you see the httpd.exe and mysqld.exe running at all when using DesktopServer’s “Stop or restart…”, followed by “Restart…” option? You should *at least* see the programs appears on the tasklist for at least a second….

    What happens when you visit http://127.0.0.1 ?

    August 1, 2012 at 11:06 am #5451

    stano7
    Subscriber

    I haven’t tried these yet but one other tidbit that I just remembered, When I installed XAMPP from the apache friends site it was the x64 version.

    How do I know if I have removed all of the apache files?  I did not do anything extra from the standard installation fo XAMPP.

    August 1, 2012 at 3:33 pm #5466

    Stephen Carnam
    Key Master

    I’m pretty sure that deleting the c:\xampp folder or c:\Program Files\xampp would do the trick. If the files persist, you can try a fresh reboot; the files will have a greater chance of not being accessed/open and easier to delete. Be sure to empty your recycle bin as simply deleting the files may just move them to the trash bin but not necessarily remove active processes from memory.

    A fresh reboot with the files no longer present (or in the recycle bin) will ensure that they are not loaded or inhibiting your DesktopServer installation.

     

    August 1, 2012 at 6:19 pm #5472

    stano7
    Subscriber

    Ok, I did as you said and deleted everything from my recycle bin reinstalled Serverpress after deleting my recycle bin and checking that XAMPP and XAMPPlite were off of the c drive.  I also cleaned my registry for any orphaned fines.

    Same error.  Can not find server.  127.0.0.1 comes up with “Can not find server”.  port 408 is occupied with imhost, windows audio, DHCP Client, eventlog.  When I try to turn these off I am not given permission, “access denied”.

     

    August 1, 2012 at 6:25 pm #5473

    Stephen Carnam
    Key Master

    Let’s try one more item: run the cports.exe program as “Administrator” (via right click). Please take a moment to visit this post:

    http://serverpress.com/topic/database-sql-missing-in-zip-import/#post-3697

    The download link is here
    http://www.nirsoft.net/packages/networktools.zip

    Do you see any process on port 80 or 443?

    August 2, 2012 at 4:58 am #5474

    stano7
    Subscriber

    I’ve tried everything:(  nothing running on port 80 or 443 after running desktopserver.

    http://localhost -
    Oops! Google Chrome could not connect to localhost
    httpd.exe in c:\xampplite\apache\bin

    mysqld.exe in c:\xampplite\mysql\bin

    About ready to throw in the towel and wipe my HD and reinstall Windows7.

     

    August 2, 2012 at 5:04 am #5475

    Stephen Carnam
    Key Master

    Can you provide the content of your c:\windows\system32\drivers\etc\hosts file? If it is missing, this could be the problem too.

    August 2, 2012 at 4:06 pm #5482

    stano7
    Subscriber

    I do have the host file.  Attached.

    Attachments:

    You must be logged in to view attched files.

    August 3, 2012 at 2:53 pm #5487

    Stephen Carnam
    Key Master

    This hosts file looks normal. At this point (without an Apache error log), we may need to take a look at your Windows Event log to see if there is any services or components throwing persistent errors.

    http://maximumpcguides.com/windows-7/how-to-check-system-logs-in-the-event-viewer/

    Do you see any mentions of Apache, httpd, or related components?

    August 3, 2012 at 3:53 pm #5488

    stano7
    Subscriber

    OK,

    I re-installed windows 7.  Re-installed Serverpress.  During the installation I received a popup that the installation did not install correctly.  And asked if I wanted to install with the recommened settings.  I did this.

    Ran Serverpress.  firewall popups for both apache and mysql asking for allowance to run these.  I click yes to both.

    Same error.  Server not found.

    From the logs I’m thinking that the installation was corrupted.  I uninstalled using Serverpress installation file.  rebooted.  and tried reinstalling it with the firewall OFF.  same result.

    Here are events log:

    - <Event xmlns=”http://schemas.microsoft.com/win/2004/08/events/event“>

    - <System>

    <Provider Name=”MySQL” />

    <EventID Qualifiers=”49152“>100</EventID>

    <Level>4</Level>

    <Task>0</Task>

    <Keywords>0×80000000000000</Keywords>

    <TimeCreated SystemTime=”2012-08-03T23:00:58.000000000Z” />

    <EventRecordID>940</EventRecordID>

    <Channel>Application</Channel>

    <Computer>Work-PC</Computer>

    <Security />

    </System>

    - <EventData>

    <Data>Plugin ‘FEDERATED’ is disabled.</Data>

    </EventData>

    </Event>

    - <Event xmlns=”http://schemas.microsoft.com/win/2004/08/events/event“>

    - <System>

    <Provider Name=”MySQL” />

    <EventID Qualifiers=”49152“>100</EventID>

    <Level>4</Level>

    <Task>0</Task>

    <Keywords>0×80000000000000</Keywords>

    <TimeCreated SystemTime=”2012-08-03T23:00:58.000000000Z” />

    <EventRecordID>941</EventRecordID>

    <Channel>Application</Channel>

    <Computer>Work-PC</Computer>

    <Security />

    </System>

    - <EventData>

    <Data>Event Scheduler: Loaded 0 events</Data>

    </EventData>

    </Event>

    - <Event xmlns=”http://schemas.microsoft.com/win/2004/08/events/event“>

    - <System>

    <Provider Name=”MySQL” />

    <EventID Qualifiers=”49152“>100</EventID>

    <Level>4</Level>

    <Task>0</Task>

    <Keywords>0×80000000000000</Keywords>

    <TimeCreated SystemTime=”2012-08-03T23:00:58.000000000Z” />

    <EventRecordID>942</EventRecordID>

    <Channel>Application</Channel>

    <Computer>Work-PC</Computer>

    <Security />

    </System>

    - <EventData>

    <Data>c:\xampplite\mysql\bin\mysqld.exe: ready for connections. Version: ’5.1.41′ socket: ” port: 3306 Source distribution</Data>

    </EventData>

    </Event>

    - <Event xmlns=”http://schemas.microsoft.com/win/2004/08/events/event“>

    - <System>

    <Provider Name=”Microsoft-Windows-Search” Guid=”{CA4E628D-8567-4896-AB6B-835B221F373F}” EventSourceName=”Windows Search Service” />

    <EventID Qualifiers=”32768“>3036</EventID>

    <Version>0</Version>

    <Level>3</Level>

    <Task>3</Task>

    <Opcode>0</Opcode>

    <Keywords>0×80000000000000</Keywords>

    <TimeCreated SystemTime=”2012-08-03T22:55:54.000000000Z” />

    <EventRecordID>915</EventRecordID>

    <Correlation />

    <Execution ProcessID=”0” ThreadID=”0” />

    <Channel>Application</Channel>

    <Computer>Work-PC</Computer>

    <Security />

    </System>

    - <EventData>

    <Data Name=”ExtraInfo“>Context: Windows Application, SystemIndex Catalog Details: A server error occurred. Check that the server is available. (HRESULT : 0×80041206) (0×80041206)</Data>

    <Data Name=”URL“>mapi://{S-1-5-21-2046116691-3773260348-1982368731-1001}/</Data>

    </EventData>

    </Event>

    August 3, 2012 at 4:20 pm #5489

    Stephen Carnam
    Key Master

    Did  you do a complete re-installation or an install a top your existing installation? DesktopServer is tested on new OEM Windows installs. We’re not familiar with the “did not install correctly” dialog. Are you sure this wasn’t the “Did this install correctly?” dialog? The later is a question that Microsoft uses to gather information about third-party applications with the option to cancel sending private information. There is an option to re-run the installation in an effort to compensate for applications that might have trouble with the latest version of Windows. This isn’t necessary.

    Every copy of Windows (since XP service pack 2) comes with a built in firewall. This should not be confused with a third-party firewall installed by anti-malware applications like “Norton Security”, etc. Regardless of the firewall setting or “Allowing” or “Denying” access; DesktopServer should work. The firewall only comes into play when another computer or mobile device is being used to test your website. Because you are working on your local computer, the firewall state will not matter.

    The good  news is that since you were asked to allow Apache and MySQL to run from your firewall tells us this: MySQL and Apache actually ran! This means that an error log was generated in your c:\xampplite\apache\logs\error.log and the file should be present there. In addition, you should be able to visit http://127.0.0.1 in your web browser and see the bright orange XAMPP logo screenshot on actual Windows 7  machine.

    Do you see the logo when visiting http://127.0.0.1 ?  (screen shot below)

    Attachments:

    You must be logged in to view attched files.

    August 5, 2012 at 2:58 pm #5513

    stano7
    Subscriber

    http://127.0.0.1 = Internet Explorer cannot display the webpage

    No  c:\xampplite\apache\logs\error.log  file.

    August 5, 2012 at 6:09 pm #5518

    Stephen Carnam
    Key Master

    Hello Stano7,
    Unfortunately it appears that your system is incompatible. We simply don’t know why at this point as a minimal error log should have at least been created. It is curious that the firewall indicates that httpd.exe did go into memory and got as far as talking on port 80, thus prompting you to allow it public access. Again, denying or allowing does not matter as the firewall should not be an issue on your local machine. This could be related to a misbehaving lower level system driver (although usually an error message or ‘crash’ message should appear).

    Regards,
    Stephen

    August 5, 2012 at 8:09 pm #5519

    stano7
    Subscriber

    I tried to install the lite version again just out of curiosity since in worked originally.  This is the error message that I received.

    I am using Dreamweaver CS6.  Has the program been tested with the latest update from Adobe?

    Attachments:

    You must be logged in to view attched files.

    August 5, 2012 at 8:12 pm #5521

    stano7
    Subscriber

    I am also running Windows 7 x64 SP1 with the latest security updates from Microsoft.  Any possibility that one of the Microsoft latest updates is correpting the installation?

    August 5, 2012 at 9:49 pm #5522

    Stephen Carnam
    Key Master

    Hello Stan,

    This is not an error message. This is the Microsoft Windows compatibility message we spoke about in the prior post. Simply click cancel or “This program installed correctly”. DesktopServer has been testes on Windows 7 with latest service packs and with Dreamweaver CS6. In fact, we’ve just been published in the latest Visual Quick Start Guide for Dreamweaver CS6 featuring compatibility with Windows 7.

    Regards,
    Stephen

    August 6, 2012 at 7:22 pm #5535

    stano7
    Subscriber

    Thanks for being patient! I’m trying to still work through this…

    Look at the attached image. It is a screen shot of what happens when I run the xampp control panel. Getting this error with Apache.

    Looked in the system event log and found this error: The Apache service named reported the following error:
    >>> (OS 3)The system cannot find the path specified. : httpd.exe: could not open error log file C:\\xampplite\\apache\\logs\\error.log.

    What do you make of this?

    Attachments:

    You must be logged in to view attched files.

    August 6, 2012 at 7:37 pm #5537

    Stephen Carnam
    Key Master

    It appears that you are running Apache as a system service. This can prevent DesktopServer from restarting the service and making changes needed to manage Apache (however, it should have started non-the less). Please uncheck the “svc” check box next to the Apache option in the control panel.

    The message you found in the system event viewer is strange. Do you have a folder for the c:\xampplite\apache\logs ? If the folder is missing, this could be the cause of the issue. However, both the Installer or the manual installation process should have created an empty c:\xampplite\apache\log folder.

    August 7, 2012 at 4:18 am #5541

    stano7
    Subscriber

    SUCCESS! I manually added a “logs” folder to the apache folder within xampplite (c:\xampplite\apache\logs). Now it works fine.

    I don’t know what would prevent that from being created during installation, but there you have it. I did try both manual and automated installations with the same results.

Viewing 30 posts - 1 through 30 (of 32 total)

You must be logged in to reply to this topic.